comp.lang.ada
 help / color / mirror / Atom feed
From: tmoran@acm.org
Subject: Re: Small question concerning use
Date: Wed, 17 Oct 2001 00:18:33 GMT
Date: 2001-10-17T00:18:33+00:00	[thread overview]
Message-ID: <t74z7.24113$gT6.15012072@news1.rdc1.sfba.home.com> (raw)
In-Reply-To: 9qi8ls$a2g1@news.cis.okstate.edu

> How do you name a variable so it doesn't conflict with other
> names when "use"d, but doesn't do too much repetition. What should
> Ada.Streams.Stream_Element_Count have been named? (Count's just an awful
> name, anyway, even outside a "use" enviroment; a count of what?)
  Sometimes you just have to decide at design time whether the package
is going to be "use"d or not.  If not, then
  package Apples
    Count : Integer;
lets you say
  Apples.Count :=
but, as you say,
  use Apples;
  ...
  Count :=
would be confusing.
OTOH, Ada.Streams.Stream_Element_Count was clearly designed with the
intention of "use Ada.Streams", in which case Stream_Element_Count
is very readable, while Ada.Streams.Stream_Element_Count is ugly.



  reply	other threads:[~2001-10-17  0:18 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2001-10-15 22:28 Small question concerning use Eric Merritt
2001-10-16  6:34 ` Rename is much better Petter Fryklund
2001-10-16 12:28 ` Small question concerning use Marc A. Criley
2001-10-16 13:27 ` Ted Dennison
2001-10-16 19:31   ` Darren New
2001-10-16 20:26     ` Ted Dennison
2001-10-16 21:26       ` David Starner
2001-10-17  0:18         ` tmoran [this message]
2001-10-17  2:48           ` Darren New
2001-10-17 10:52             ` Larry Kilgallen
2001-10-17 13:48             ` Ted Dennison
2001-10-17 14:21         ` Ted Dennison
2001-10-16 20:35     ` Ted Dennison
2001-10-16 13:54 ` Marin David Condic
2001-10-18 18:46 ` Dr. Michael Paus
replies disabled

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox