comp.lang.ada
 help / color / mirror / Atom feed
From: "Nasser M. Abbasi" <nma@12000.org>
Subject: Re: basic question on nested packages
Date: Sat, 28 Jul 2012 07:52:10 -0500
Date: 2012-07-28T07:52:10-05:00	[thread overview]
Message-ID: <jv0na2$b3p$1@speranza.aioe.org> (raw)
In-Reply-To: a7i3ndF8h9U1@mid.individual.net

On 7/28/2012 7:19 AM, Niklas Holsti wrote:
> On 12-07-28 06:22 , Nasser M. Abbasi wrote:
>> I'd like to improve the structure of the Ada lapack binding
>> to make it easier to use.
>>
>> The official Fortran lapack is structured as follows
>>
>>                                 lapack
>>                                   +
>>                                   |
>>                  +----------------+-------------------+
>>                  |                |                   |
>>               driver routines    computational     auxiliary
>>

....
>>
>> Hence it will be, for the API's
>>
>>     lapack.driver.foo()
>>     lapack.comp.foo()
>>     lapack.aux.foo()
>>     lapack.IO.foo()

>
> I'm going to play devil's advocate and ask why you don't put it all in
> one package, lapack.
>
> Is there any benefit to writing a call as "lapack.driver.SGESV" instead
> of directly as "lapack.SGESV"? Is there some risk of ambiguity, with the
> name SGESV defined with different meaning in the different packages?
>

Main reason is just to keep things organized as in the Fortran tradition
of the original lapack:

http://www.netlib.org/lapack/lug/node22.html

"
The subroutines in LAPACK are classified as follows:
     driver routines, ....
     computational routines.....
     auxiliary routines....
"

So someone used to using lapack would find it easier if there are 3
packages that correspond to those 3 areas.

I assume that is the reason Wasu Chaopanon (who made the binding)
did it this way as you can see here (one of hosting sites for
the binding)

http://www.mirrorservice.org/sites/ftp.cs.nyu.edu/pub/gnat/OLD/contrib/lapack-ada/README

So, I think it is better to keep this layout? But putting all
the packages all under one package name "lapack" in order to reduce
name space is all what I did.

thanks,
--Nasser



  reply	other threads:[~2012-08-01  2:50 UTC|newest]

Thread overview: 11+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-07-28  3:22 basic question on nested packages Nasser M. Abbasi
2012-07-28  5:27 ` Nasser M. Abbasi
2012-07-28  5:36   ` Shark8
2012-07-28  9:01     ` Nasser M. Abbasi
2012-07-28  9:53       ` AdaMagica
2012-07-28 12:54         ` J-P. Rosen
2012-07-28 12:19 ` Niklas Holsti
2012-07-28 12:52   ` Nasser M. Abbasi [this message]
2012-07-28 13:34     ` Niklas Holsti
2012-07-29  1:19       ` Nasser M. Abbasi
2012-07-29 23:05         ` Niklas Holsti
replies disabled

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox