comp.lang.ada
 help / color / mirror / Atom feed
From: tmoran@acm.org
Subject: Re: Naming convention for classes?
Date: Wed, 04 Feb 2004 08:06:35 GMT
Date: 2004-02-04T08:06:35+00:00	[thread overview]
Message-ID: <fK1Ub.87451$U%5.467557@attbi_s03> (raw)
In-Reply-To: MPG.1a89fe0b56e324d998968e@news.sover.net

>  Today : Date.Object;
>  Today : Date;
>The second approach seems natural ...
  Agreed.
Remember that a package can contain more than one type definition, and
in general a package is a higher level of abstraction than any one of
its contents.  So you might do
  package Timestamps is
    type Date is ...
or
  package Historical_Records is
    type Date is ...
But as noted, it's often not obvious and it comes down to a personal
stylistic preference - presumably a reasonably consistent one.
Have you looked at "Ada Quality and Style"?



  parent reply	other threads:[~2004-02-04  8:06 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2004-02-03 23:52 Naming convention for classes? Peter C. Chapin
2004-02-04  0:27 ` Jeffrey Carter
2004-02-04  2:31   ` Peter C. Chapin
2004-02-04  8:57     ` Jean-Pierre Rosen
2004-02-04 11:52       ` Peter C. Chapin
2004-02-04 14:02         ` Jean-Pierre Rosen
2004-02-05 12:18           ` Stuart Palin
2004-02-04 14:13         ` Martin Krischik
2004-02-04  9:13     ` Preben Randhol
2004-02-04 14:57     ` Georg Bauhaus
2004-02-04 19:01     ` Jeffrey Carter
2004-02-04  8:06 ` tmoran [this message]
2004-02-04 11:49   ` Peter C. Chapin
2004-02-04 12:36     ` Preben Randhol
2004-02-04 12:41       ` Preben Randhol
2004-02-04 14:09       ` Martin Krischik
replies disabled

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox