comp.lang.ada
 help / color / mirror / Atom feed
From: "SteveD" <nospam_steved94@attbi.com>
Subject: Re: Naming conventions
Date: Thu, 25 Jul 2002 04:28:26 GMT
Date: 2002-07-25T04:28:26+00:00	[thread overview]
Message-ID: <K7L%8.158363$uw.93944@rwcrnsc51.ops.asp.att.net> (raw)
In-Reply-To: 3D3F58F4.9050305@hotmail.com

"Ryan Tarpine" <rtarpine@hotmail.com> wrote in message
news:3D3F58F4.9050305@hotmail.com...
> Coming from C++, what I used to think of as a class (a type and its
> associated methods) is now roughly equivalent to a package....

A package is closer to a C++ namespace than a class.  A C++ class
corresponds roughly to an Ada tagged type with its associated procedures and
functions.

>  Whenever I try to name a package, I use what I normally think of as the
type
> itself.  For example, I would put a vector type in a package Vector or a
> regular expression type in a package Regular_Expression.  However, once
> I name the package, I am at a loss for what to call the data type inside.
>
> I've been appending '_Type' to the package names, making names like
> Vector_Type, but I don't think that is the Right Thing(TM).  I've been
> skimming the style guides (which I heartily recommend all newbies to
> do), and I've seen a little bit of calling the type simply Instance or
> Object.  When used with the package name this looks nice, such as
> Vector.Instance.  What do the Ada gurus normally do for this? :)

If you want to follow this sort of convention, perhaps you should use:

package Vector_Package is

  type Vector_Type is abstract tagged null record with private;

  ...

etc.

I'm sure you'll get all kinds of feedback that this convention is bad, but
if
you're consistant and make things readable it really doesn't matter what
conventions you follow.

SteveD







  parent reply	other threads:[~2002-07-25  4:28 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2002-07-25  1:48 Naming conventions Ryan Tarpine
2002-07-25  2:51 ` Ted Dennison
2002-07-25  3:11 ` tmoran
2002-07-25  4:28 ` SteveD [this message]
2002-07-25 11:50 ` David C. Hoos, Sr.
2002-07-25 15:20 ` Stephen Leake
2002-07-25 16:24   ` Jean-Pierre Rosen
  -- strict thread matches above, loose matches on Subject: below --
1987-11-13 23:10 Michael.Rissman
replies disabled

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox