=?utf-8?Q?Yannick_Duch=C3=AAne_=28Hibou57?= =?utf-8?Q?=29?= expounded in news:op.vlibn4shule2fv@garhos: > Le Mon, 01 Nov 2010 20:19:51 +0100, Jeffrey Carter > a écrit: >> No, not nice. Terrible. >> >> "_Type" is just noise; you could use "_Global_Nuclear_Warfare" just >> as > >> well. You should never be adding unnecessary noise to your code. > > Actually, this convention appears in many places, like the ARM. Ex: > > subtype Buffer_Type is > System.Storage_Elements.Storage_Array (1..Buffer_Size); > > And to talk about good names, you may agree _Global_Nuclear_Warfare > does not express the same at all as _Type does. This is even more > clear if you have some _Access. > >> >> S/W engineering involves putting in the effort to think of good names > >> for everything in your code. "_Type" is a kludge to avoid doing that >> thinking. There is a good practical case for _Type, IMO. If Buffer_Type is defined simply as Buffer, then we develop an inconvenient name clash: > subtype Buffer is > System.Storage_Elements.Storage_Array (1..Buffer_Size); In use now: declare Buffer : Buffer; -- hmmmm begin ... Buffer_Type avoids this difficulty: declare Buffer : Buffer_Type; begin ... So while I'd agree that "_Type" is noisy, it is sometimes the right choice. If you can devise a better name for the type, like perhaps Storage_Buffer, then perhaps that is preferred. Warren