From mboxrd@z Thu Jan 1 00:00:00 1970 X-Spam-Checker-Version: SpamAssassin 3.4.4 (2020-01-24) on polar.synack.me X-Spam-Level: X-Spam-Status: No, score=-1.3 required=5.0 tests=BAYES_00,INVALID_MSGID autolearn=no autolearn_force=no version=3.4.4 X-Google-Language: ENGLISH,ASCII-7-bit X-Google-Thread: 103376,9b17a1f51a26de9d X-Google-Attributes: gid103376,public From: tmoran@bix.com Subject: Re: An array of records within an array of records (Still a problem) Date: 1998/05/02 Message-ID: <6ifs4p$fl8@lotho.delphi.com>#1/1 X-Deja-AN: 349660058 Organization: Delphi Internet Services Newsgroups: comp.lang.ada Date: 1998-05-02T00:00:00+00:00 List-Id: > type cd_track_array is array(1..3) of cd_track; > new_cd_track:cd_track_array; > ... > id:new_cd_track; You need id:cd_track_array; What you have now is like A : Integer; B : A; It's a good idea to pay a lot of attention to naming. 'cd_track_array' could be a particular array of cd_track's, or it could be, as it is here, a type - a general description of any set of three cd_track's. Some people like to put _type or _t or make a plural for a type name to distinguish it from a variable name, or perhaps use _array for the type and _list for the variable, or prefix the variable with The_ or A_, or whatever. It can be really helpful if you adopt some convention and then stick to it. And to the extent your programs are to be read by others, it's good if you and they share the same conventions. Hoping this thread doesn't turn into another war over which convention is 'right'. Tom Moran